Web services outage

Incident Report for Yavapai College

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 08:03 MST

Investigating

We are currently investigating this issue.
Posted Apr 15, 2025 - 01:15 MST
This incident affected: Yavapai College Website, myYC Portal, Banner Information System, and Network Infrastructure.