DUO Issues related to SMS and Phone call delivery

Incident Report for Yavapai College

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 20:34 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2025 - 15:53 MST

Investigating

From Duo - We are currently investigating an issue causing Admin Panel login and SMS/Phone Call delivery failures across all deployments.

If you can access your Admin Panel, please utilize our other MFA methods such as Push, Passcodes, Hardware Tokens, and Security Keys in the meantime. https://duo.com/docs/policy#authentication-methods. Check https://status.duo.com/ for updates.
Posted Feb 13, 2025 - 11:59 MST