MyYC Portal Outage
Incident Report for Yavapai College
Resolved
This incident has been resolved.
Posted Jan 19, 2024 - 16:02 MST
Identified
We have identified the issue and implemented a workaround.
Posted Jan 19, 2024 - 10:28 MST
Investigating
ITS is currently investigating YC portal access issues, we will update you as more information becomes available
Posted Jan 19, 2024 - 10:19 MST
This incident affected: Yavapai College Website.