Payment Center (Cashnet) login error
Incident Report for Yavapai College
Resolved
This incident has been resolved.
Posted Mar 25, 2024 - 15:47 MST
Update
We are currently experiencing an issue with our authentication to our payment provider (CashNet). Users may receive an error message: “Our system is not able to recognize you.” We are currently working with the vendor to resolve the issue. For updates, please visit status.yc.edu.

Thank you for being so patient as we address this issue.
ITS Department
Posted Mar 25, 2024 - 10:02 MST
Investigating
We are currently investigating this issue.
Posted Mar 25, 2024 - 08:07 MST