25Live Scheduling System Outage
Incident Report for Yavapai College
Resolved
This incident has been resolved.
Posted Nov 02, 2023 - 11:58 MST
Identified
The vendor is experiencing a power issue at their data center. They will notify us when the issue is addressed.
Posted Nov 02, 2023 - 10:09 MST