Canvas Login Issue

Incident Report for Yavapai College

Resolved

This incident has been resolved.
Posted Apr 15, 2026 - 17:06 MST

Monitoring

Our vendor has addressed the issue (https://status.instructure.com/). Thanks for your patience as we waited for this fix!
Posted Apr 15, 2026 - 10:59 MST

Investigating

We are currently facing an issue where users who log in to the myYC portal are then prompted to log in again to access Canvas. If you enter your username and password again, you will be able to access Canvas. We are actively working with the vendor to resolve this issue. Thank you for your patience!
Posted Apr 14, 2026 - 16:56 MST
This incident affected: Canvas.