myYC Portal - Banner Issue
Incident Report for Yavapai College
Resolved
This incident has been resolved.
Posted Sep 04, 2024 - 17:14 MST
Investigating
We are currently investigating this issue.
Posted Sep 04, 2024 - 16:36 MST
This incident affected: Banner Information System.