Microsoft Service Issues

Incident Report for Yavapai College

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 15:55 MST

Update

From Microsoft
We've completed the deployment of a healthy configuration, and we're continuing our active traffic balancing efforts as well as monitoring corresponding service telemetry to ensure widespread recovery.
Posted Oct 29, 2025 - 13:05 MST

Update

From Microsoft:
Current status: We've halted the rollout of the impacting configuration change. We're continuing our efforts to route service traffic away from affected infrastructure where the change was already applied, to recover service availability as quickly as possible. In parallel, we're working to revert the impacted infrastructure to a previous healthy state.
Posted Oct 29, 2025 - 11:12 MST

Update

Latest update from Microsoft:
We've identified a recent configuration change to a portion of Azure infrastructure which we believe is causing the impact. We're pursuing multiple remediation strategies, including moving traffic away from the impacted infrastructure and blocking the offending change. We'll provide an estimated recovery time as soon as possible.
Posted Oct 29, 2025 - 10:30 MST

Identified

Latest update from Microsoft:
Current status: We're rerouting affected traffic to alternate healthy infrastructure as a near-term resolution while our investigation into the source of the issue is ongoing.
Posted Oct 29, 2025 - 10:07 MST

Investigating

Microsoft services are currently experiencing difficulties. They handle our SSO services as well as the 365 suite.
Posted Oct 29, 2025 - 09:43 MST
This incident affected: Azure Single Sign-On and Office 365.