Microsoft Login Services Certificate Issue
Incident Report for Yavapai College
Resolved
This issue has been resolved. Unfortunately, it happened overnight, and technicians could not respond until this morning. We apologize for the inconvenience.
Posted Feb 25, 2021 - 08:04 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 25, 2021 - 06:42 MST
This incident affected: Office 365 Single Sign-On.