myYC login issues

Incident Report for Yavapai College

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 10, 2026 - 10:57 MST

Investigating

We are currently investigating the issue. Please use https://experience.elluciancloud.com/myyc as a short term solution.
Posted Aug 10, 2026 - 10:19 MST
This incident affects: myYC Portal.