Emburse - Travel and Invoice System

Incident Report for Yavapai College

Resolved

The vendor has confirmed that the Emburse system is operational now. Users can now access the system.
Posted Sep 15, 2026 - 11:14 MST

Identified

The vendor is working on the issue.
Posted Sep 15, 2026 - 11:08 MST