Server/Storage Issues

Incident Report for Yavapai College

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 13:06 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2025 - 09:04 MST

Identified

Server/Storage Issue Update
After working with our storage vendor, we have a possible remedy that we are currently working on that may return us to normal operations for our local server environments. This work will take several hours to complete, and we are anticipating being completed around 9 PM. At that juncture, we should be able to tell if we are stable and ready to resume normal operations. Unfortunately, sometimes there are no clear-cut paths to resolve new issues as there can be many variables. We will post updates to status.yc.edu, and we continue to ask for your patience as we attempt to mitigate these issues.

Thanks for your understanding
ITS Department
Posted Mar 25, 2025 - 15:29 MST

Investigating

Recently, we have been experiencing issues related to the storage that our internal servers rely on to provide services. In short, the performance is severely degraded due to an unknown problem we are working on with the vendor. Progress with the vendor has been slow and very frustrating as we try to resolve the issue. Some systems are more sensitive to degraded storage performance (e.g., Banner-related services, network shares). Alternative services, such as Microsoft OneDrive, will be more stable during this period and would be a good possibility for working and collaborating on files. Pending our results with the vendor troubleshooting, we may have to take all our systems down to reset the storage device, which will cause some downtime (~ 30 minutes to 1 hour). If we need to do this, we will provide notice. We apologize for the inconvenience this issue has caused. Our team will do our best to try to mitigate disruptions.

Thanks for your patience and understanding.
ITS Department
Posted Mar 25, 2025 - 10:22 MST
This incident affected: Yavapai College Website, myYC Portal, Banner Information System, and Degree Works.