Duo and Entra (myYC logins) Error

Incident Report for Yavapai College

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 10:17 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2026 - 09:41 MST

Update

No official announcement from Duo, but it appears the service is coming back online.
Posted Feb 23, 2026 - 09:30 MST

Update

We are continuing to work on a fix for this issue.
Posted Feb 23, 2026 - 08:15 MST

Identified

From https://status.duo.com/

Investigating - We are currently investigating an issue where 504 Gateway timeouts are present when accessing Entra when Duo is called for MFA.
Feb 23, 2026 - 10:04 EST
Posted Feb 23, 2026 - 08:15 MST

Investigating

Duo is currently reporting an issue.
Posted Feb 23, 2026 - 08:06 MST
This incident affected: myYC Portal and Azure Single Sign-On.