Office 365 Login Issue
Incident Report for Yavapai College
Resolved
This incident has been resolved.
Posted Feb 04, 2023 - 20:02 MST
Investigating
We are currently investigating this issue.
Posted Feb 04, 2023 - 18:31 MST
This incident affected: Office 365 Single Sign-On.