YC Website Page Loading Issues
Incident Report for Yavapai College
Resolved
This incident has been resolved.
Posted Feb 03, 2020 - 07:22 MST
Identified
ITS has identified intermittent errors when loading pages across our website. Users may periodically see error messages such as "No response received", or pages may show no content at all. If this occurs, simply wait a few minutes and try again. Our developers are working to resolve these issues as soon as possible.
Posted Jan 22, 2020 - 12:54 MST
This incident affected: Yavapai College Website.