Website & Banner Outage
Incident Report for Yavapai College
Resolved
The YC homepage and Banner are now operational.
Posted Nov 07, 2018 - 08:41 MST
Investigating
The YC homepage and most Banner services are currently inaccessible. We are investigating the issue.

Some third-party services like Canvas (https://canvas.yc.edu) and Office 365 (https://portal.office.com) may still be accessed via the provided links.
Posted Nov 07, 2018 - 08:31 MST
This incident affected: Yavapai College Website and Banner Single Sign-On.