25Live Maintenance
Incident Report for Yavapai College
Resolved
CollegeNET has notified us that 25Live maintenance is now complete.
Posted Jan 15, 2020 - 09:23 MST
Identified
The 25Live scheduling system is currently undergoing maintenance by the provider. Availability may be intermittent through tomorrow (1/15). We will post an update once CollegeNET provides more information.
Posted Jan 14, 2020 - 10:45 MST
This incident affected: 25Live.