Office 365 Sign-on Problem
Incident Report for Yavapai College
Resolved
This incident has been resolved.
Posted May 22, 2019 - 15:10 MST
Investigating
We are experiencing intermittent issues with sign-in to the Office 365 portal.
Posted May 22, 2019 - 14:42 MST
This incident affected: Office 365 Single Sign-On.