Some Banner Links Not Working
Incident Report for Yavapai College
Resolved
This incident has been resolved.
Posted Jul 24, 2021 - 09:53 MST
Investigating
We are currently investigating this issue.
Posted Jul 24, 2021 - 05:36 MST
This incident affected: Banner Single Sign-On.